about making R21-compatible files

Moderator: Moderators

Post Reply
User avatar
liquidblue aka DBV
Standard
Standard
Posts: 507
Joined: Sun Jun 12, 2005 11:45 pm

about making R21-compatible files

Post by liquidblue aka DBV » Fri Sep 07, 2007 8:45 pm

When I made my first r21 files a while back (when it first came out), you couldn't do more than 2 minutes, you had to have it in .ogg format, and a bunch of other crap.

so basically, what i'm asking is;

does anyone here have a tutorial/can post a tutorial on what exactly is needed to be done to get a file to work on r21 now, and let it be longer than 2 minutes long, etc.?


User avatar
danc1005
Heavy
Heavy
Posts: 3237
Joined: Tue Feb 28, 2006 7:21 pm
Location: Da Fort
Contact:

Post by danc1005 » Fri Sep 07, 2007 9:56 pm

Everything's the same for the most part, but to use files longer than 2 minutes, refer to post above me.
Image

User avatar
liquidblue aka DBV
Standard
Standard
Posts: 507
Joined: Sun Jun 12, 2005 11:45 pm

Post by liquidblue aka DBV » Sat Sep 08, 2007 1:39 am

ggggggggg thanks

Flound3r
Standard
Standard
Posts: 131
Joined: Sun Mar 25, 2007 2:55 pm
Contact:

Post by Flound3r » Sun Sep 09, 2007 8:48 am

If you don't wanna click..

Basically put the Length Patch somewhere easy (mine's on my desktop) then drag and drop the OGG onto it. A black screen should pop up for like half a second and then you're done! It only works on R21 though (gay Laser Flash...)
d0nt t4lk l1k3 th15 pl0x

User avatar
liquidblue aka DBV
Standard
Standard
Posts: 507
Joined: Sun Jun 12, 2005 11:45 pm

Post by liquidblue aka DBV » Tue Sep 18, 2007 4:54 am

oh, one other thing too;
i distinctly remember making some simfiles last time i was into this, and they were dead on synch/beat at home on stepmania, but in the arcade, a few of them were a full beat off.

any reasons for this or do you think it was just some random occurance/ITG machine was fucked up?

EDIT: and i assume to get ogg files louder i should just raise the volume in some audio editing program, since converting a file to ogg kills the volume

User avatar
BigBadOrc
Standard
Standard
Posts: 588
Joined: Mon Sep 04, 2006 8:53 pm
Location: Indy
Contact:

Post by BigBadOrc » Tue Sep 18, 2007 8:48 am

liquidblue aka DBV wrote:oh, one other thing too;
i distinctly remember making some simfiles last time i was into this, and they were dead on synch/beat at home on stepmania, but in the arcade, a few of them were a full beat off.
Sound cards have different delays. That means a song could be on sync on your computer and off sync on someone else's computer. So, the solution is that stepmania has two different offsets. It has a song offset for each individual song, and it has a global offset so you can match your machine to an arcade cabinet. I'm not sure if all versions of stepmania have this, but 3.95 does. 3.95 should be linked to on ITGfreak, along with a very good ITG skin. So get that, and then get a song that you know is on sync on an arcade cabinet. http://boxorroxors.net/ has plenty of these. Then sync your global offset to that song. Press f6 once for sync to song, one more time for sync to global.
groovestats
<3 blackcat

User avatar
liquidblue aka DBV
Standard
Standard
Posts: 507
Joined: Sun Jun 12, 2005 11:45 pm

Post by liquidblue aka DBV » Tue Sep 18, 2007 4:26 pm

Ok, so would you say the songs in;

http://boxorroxors.net/downloads.php?di ... roove%202/

are more than likely going to be on sync?

The nearest ITG2 to me is a 90 minute drive, sooo it's not as if i can just drive back and forth testing it, lol

User avatar
BigBadOrc
Standard
Standard
Posts: 588
Joined: Mon Sep 04, 2006 8:53 pm
Location: Indy
Contact:

Post by BigBadOrc » Wed Sep 19, 2007 8:49 am

Im pretty sure those songs came directly from a machines hard drive. although it looks like it wasnt completely unlocked.

and ASDF@#!@#$!@#$ my single quote button is not working wtf. i can type double quotes tho which is the same damn button "

Edit: rofl.. fuck winamp global hotkeys.. dunno how my single quote button got bound to "next song"
groovestats
<3 blackcat

User avatar
hascoolnickname
Heavy
Heavy
Posts: 1921
Joined: Sat Feb 26, 2005 10:47 pm
Location: :noitacoL

Post by hascoolnickname » Wed Sep 19, 2007 5:29 pm

BigBadOrc wrote:Edit: rofl.. fuck winamp global hotkeys.. dunno how my single quote button got bound to "next song"
hax obviously
indyddr.com - "THE DUMBEST forum on the Web."

User avatar
MonMotha
Site Code Monkey
Site Code Monkey
Posts: 2487
Joined: Sun Jan 23, 2005 9:18 pm

Post by MonMotha » Wed Sep 19, 2007 6:09 pm

The reason ogg vorbis files often sound softer is because they generally have replaygain, which attempts to normalize the volume levels of everything so you don't constantly have to fiddle with the volume control. Since most CDs are normalized to full scale peaks, this means things have to get softer. You can just strip off the replaygain info if you don't like the functionality.

Interestingly, making the source audio louder won't actually fix this particular problem. In fact, it will only introduce clipping artifacts and lower dynamic range.
A normality test:
+++ATH
If you are no longer connected to the internet, you need to apply more wax to your modem: it'll make it go faster.
If you find this funny, you're a nerd.
If neither of the above apply, you are normal. Congratulations.

User avatar
liquidblue aka DBV
Standard
Standard
Posts: 507
Joined: Sun Jun 12, 2005 11:45 pm

Post by liquidblue aka DBV » Wed Sep 19, 2007 7:17 pm

MonMotha wrote:The reason ogg vorbis files often sound softer is because they generally have replaygain, which attempts to normalize the volume levels of everything so you don't constantly have to fiddle with the volume control. Since most CDs are normalized to full scale peaks, this means things have to get softer. You can just strip off the replaygain info if you don't like the functionality.

Interestingly, making the source audio louder won't actually fix this particular problem. In fact, it will only introduce clipping artifacts and lower dynamic range.
Sorry to ask yet another question, but how would you strip off the replaygain info?

User avatar
MonMotha
Site Code Monkey
Site Code Monkey
Posts: 2487
Joined: Sun Jan 23, 2005 9:18 pm

Post by MonMotha » Wed Sep 19, 2007 10:26 pm

"vorbisgain -c <file.ogg>" will remove any ReplayGain tags which may be present. If you're using a frontend or 3rd party encoder, you'll just have to find the option in your encoder or frontend.

Of course, whether or not this is causing your "problem" depends on if your encoder is adding ReplayGain tags to begin with. The bare reference encoder (oggenc) does not, but many frontends and 3rd party encoders do.

It's also possible that your encoder is attenuating the audio before passing it to the encoder. The reference encoder does not do this, but 3rd party applications may. If this is what's happening, you'll just have to find out how to disable the behavior as it is a function of the encoder, not the codec (Vorbis) or container format (OGG).
A normality test:
+++ATH
If you are no longer connected to the internet, you need to apply more wax to your modem: it'll make it go faster.
If you find this funny, you're a nerd.
If neither of the above apply, you are normal. Congratulations.

User avatar
liquidblue aka DBV
Standard
Standard
Posts: 507
Joined: Sun Jun 12, 2005 11:45 pm

Post by liquidblue aka DBV » Thu Sep 20, 2007 1:21 am

MonMotha wrote:"vorbisgain -c <file.ogg>" will remove any ReplayGain tags which may be present. If you're using a frontend or 3rd party encoder, you'll just have to find the option in your encoder or frontend.

Of course, whether or not this is causing your "problem" depends on if your encoder is adding ReplayGain tags to begin with. The bare reference encoder (oggenc) does not, but many frontends and 3rd party encoders do.

It's also possible that your encoder is attenuating the audio before passing it to the encoder. The reference encoder does not do this, but 3rd party applications may. If this is what's happening, you'll just have to find out how to disable the behavior as it is a function of the encoder, not the codec (Vorbis) or container format (OGG).
OK, i'm packing for my trip, and with that and 20 other things i'm doing, i'm about to chuck my laptop out the window in trying to switch directories in the command prompt so i can even *use* oggenc.

It seems that ever since i installed the japanese language crap on here, the \ key becomes the yen sign, which apparently confuses the hell out of the command prompt, as I know how to switch directories, but it's refusing to acknowledge the command.

So with that and everything, thanks for the help guys, i'll be bringing some of my old simfiles i've converted (unfortunately without the ogg patch) with me, but as for the new stuff I planned to make, I just don't have the time. :/

If anyone's interested in making files to the songs, I think they'd make REALLY good simfiles, so i'll send you the mp3's, but yeah. (they're not too well known of songs, so i wouldn't worry about legality stuff) I only had three simfiles in mind, so yeah, three songs.

Post Reply